IBM 2210 Multiprotocol Router Information and Software

System Type: 2210

IBM Router

The IBM 2210 Nways Multiprotocol Router was released in 1997 as a versatile and comprehensive routing solution. While many mistake these routers as being exclusively Token Ring, the majority purchased and deployed were actually the Ethernet variants (despite this IBM still attempted to tailor them to token-ring as evidenced by the fact only the Token Ring variants were shown on stock photos and the brochure). Only the 2210-24M contained both Ethernet and Token Ring interfaces. Such luxury!

While being able to combine many protocols and interfaces, the -24M models are the most desirable for the unique prospect of bridging both an Ethernet and Token Ring LAN. Other solutions to bridge Token Ring and Ethernet exist such as the considerably older IBM 8209; however it is not a router like the 2210 and also suffers from some issues handling IPX on earlier models.

Because of the 2210's nature of (potentially) handling multiple interfaces, protocols and routing features later to become standard on modern routers-- it is one of the most complex routers ever made due to the fact newer routers have dropped many of the legacy interfaces and protocols simplifying everything to TCP/IP and Ethernet exclusively.

Some interfaces the 2210-24M supports:


All documentation, demonstrations, stock photos, freeware, and first party information remains property of the IBM corporation. "ibmfiles.com" is a hobbyist operated site not affiliated to the IBM corporation and does not represent IBM's opinions.
Anything reproduced here from existing public sources is only done for historical, archival, and non-profit purposes.


Index: General Info, Downloads, Installing the Configuration Program (MRS), Multiprotocol Routing Services (MRS) Version History, 2210 Storage Estimate Program, The Legacy Multiprotocol Router Library, 2210 Configuration Programs, Nways MRS and Nways MRNS - Providing 2110 Software Functions, MRS Configuration Tool - User Notes, 2210 RLAN Clients (DIALs), News - Using Frame Relay and the IBM 2210, Improved Availability, Performance Results: Release 3.0, IBM Nways Multiprotocol Routing/Access Services Version 1 Release 1, IBM 2210 Wins Data Communications Tester's Choice, AS/400 Promotional Offer, Price Chart (Historical), Connecting via Console


General Info

The IBM 2210 Nways® Multiprotocol Routers provide serious network computing solutions for a range of applications. This family of routers offers connectivity and protocol support to work with everything from a 2-client local area network (LAN) to a 1000-user TCP/IP-based wide area network (WAN).

Highlights

Security: Secure exchange of keys with Internet Key Exchange (IKE), an IPSecurity (IPSec) protocol.
IP enhancements: Dynamic Host Configuration Protocol (DHCP) server provides IP address and other configuration information to LAN-attached DHCP clients. Multiple subnets can be configured on any LAN interface. IPv6 enhancements and IPv4 enhancements include generic IP route policy.
ISP access to public network: Dynamic IP is used to retrieve a public IP address from an ISP for use on the PPP interface.
Frame relay: Differentiated Services (DS) provides two new forwarding services (per-hop behaviors) for faster or earlier transmission for IPv4 packets.
Network management: Lightweight Directory Access Protocol (LDAP) enables configuring and managing network policies in a central directory server by an administrator. Resource Reservation Protocol (RSVP) for IP and bundling of different PPP circuit types.
Connectivity: Two optional V.34 modem adapters with 4 or 8 integrated modems per adapter for analog data transmission speeds up to 33.6 Kbps.
Multiprotocol: Supported routing protocols include IP, IPX, AppleTalk, BGP-4, Banyan VINES, DECnet IV and DECnet V/OSI. Supported network protocols include Bridging (also IP Bridging Tunnel), DSLw Version 2, APPN/HPR/DLUR, and LAN emulation client.
Quality of Service (QoS): Additional Dynamic Reconfiguration allows parameters to be changed on an interface without affecting the operation of other interfaces.

Features and Benefits

Virtual private network (VPN) features: IKE automatically sets up security associations and manages their cryptographic keys. Lightweight Directory Access Protocol (LDAP) enables network policies to be centrally configured and managed. L2F and PPTP support Virtual Private Dial-up Networking by allowing remote users to dial in locally.
Protocol improvements: Dynamic Host Configuration Protocol Server (DHCP) provides IP addresses and other configuration information for LAN attached DHCP clients, IP features and Dynamic IP ease configuring the IP address to access the Internet.
Performance enhancements: For frame relay, the maximum speed for WAN adapters with external clocking is increased to 6.312 Mbps (J2). SDLC full duplex stations have the option of 2-way simultaneous (TWS) scheduling to improve polling.
Scalability: Increased interface capacity allows for more cost-effective dial support by extending the 253 limit to a limit that is not memory dependent. APPN extended border node allows large APPN networks to be subdivided for improved manageability and performance.

Key Selling Points

Designed for a wide array of customer segments. Enterprise and VPNs. Small to medium businesses. ISPs offering CPE services. Data centers with regional offices. Economical cost of ownership. Price-competitive access router with IBM service, support and ordering ease. Superior installation and management capabilities. EasyStart for Plug and Play installation. Graphical configuration program. Migration capabilities and flexible hardware design. Enhanced protocol and management capabilities. The MRS software, which is common-code based, uses open industry standards and protocols.

— Product information from the deprecated IBM networking site (2001)


Downloads

Manuals


IBM MRS (Multiprotocol Routing Services) "Configuration Program"

Presently missing MRS 3.4.


Firmware, Drivers, & Software


2210 Storage Estimate Program


Installing the Configuration Program (MRS)

Note: this info is extracted off of the SK2T-0404-05 CD-ROM (which you can freely download above). It goes into detail on how to install the "MRS" Configuration Program. I'm reformatting and mirroring the info here as there was an unfortunate assumption that MRS was not listed on this page, or completely lost. It 'probably' only makes sense to use MRS 3.3 (or higher), which can run on: OS/2, Windows, AIX.

Also to note, there are some rather strange errors with the documentation that I have also corrected, 1024x768 is not SVGA, that's XGA. While I rescued some of the older 'scraps' from the IBM FTP while it was still up in 2014, Wayback never captured any of the file downloads so despite the CD-ROM claiming you can get the files at networking.ibm.com this is no longer a possibility and only the rescued FTP and CD-ROM sources remain.

The following information describes the minimum requirements and the procedure for installing and starting the MRS Configuration Program. Note: Before proceeding, read the README file in the \config directory on this CD-ROM to obtain the latest information about requirements and any changes to the installation procedures.

Hardware and Software Requirements for the Configuration Program

Requirement IBM AIX® IBM Operating System/2 Microsoft Windows® 95 or Windows NT
Workstation RS/6000® Model 250/410 or later with minimum 80-Mhz CPU IBM-compatible PC with Intel Pentium** 166-MHz or later processor (see Note (FRST)) IBM-compatible PC with Intel Pentium 166-MHz or later processor (see Note (FRST))
RAM (minimum) 64 MB 48 MB 48 MB
CD-ROM yes yes yes
Free Disk Space 26 MB. Additionally, you will need 1 to 3 MB for each configuration file. 26 MB. Additionally, you will need 1 to 3 MB for each configuration file. 26 MB. Additionally, you will need 1 to 3 MB for each configuration file.
Swapper Size N/A 10 MB N/A
Display (minimum) Display
(1024 x 768 x 256 colors)
XGA
(1024 x 768 x 256 colors)
XGA
(1024 x 768 x 256 colors)
Mouse 3-button 2-button (see Note (MS1)) 2-button (see Note (MS1))
Software AIX for RS/6000 Version 4.1.5 or later
AIXWindows® and Environment/6000
OS/2® 3.0 or later
IBM TCP/IP 1.2.1 for OS/2 or later

Notes:

  1. (FRST) More memory and faster processors will improve the program's performance.
  2. (MS1) Functionally equivalent to a 3-button mouse.
  3. (TCP1) You must make sure that TCP/IP is installed and running before using the "Single Send or Retrieve" or "Multiple Send or Retrieve" functions. On MS Windows platforms, the Configuration Program will hang if TCP/IP is not installed and running.

The AIX version of the conversion program requires special fonts. For this program to run correctly, you must have the /usr/lib/X11/fonts/75dpi/ in your list of directories. If you do not have this directory in your Xstation Font Path, at your Xstation, enter:

xset fp+ /usr/lib/X11/fonts/75dpi/

This command adds the conversion program font directory to your Xstation Font Path. Place the above line in your .profile for future use.

Procedures for Installing the Configuration Program

The procedure you use for installing the configuration program depends on the operating system under which the program will run. "Installing on AIX", "Installing on OS/2", and "Installing on Windows" describe the steps you take to install the configuration program based on your operating system.

Before installing the configuration program, make sure that you have write access to the directory in which you are installing the configuration program. The installation process writes program files to the directory during installation and the configuration program writes information to the directory while it is running. See the appropriate README file for more detailed information.

You can obtain the Configuration Program electronically from the Web at www.networking.ibm.com/support/downloads/2210.

  1. Click on the URL above and select 2210 Configuration Program
  2. Select the desired code level under MRS V3.3 Configuration Program
  3. Select from Files in the Package at the bottom of the screen to download the files

AIX: Download the mrsaix.lpp file to a temporary directory

OS/2: Download the mrsos2.cmd file to a temporary directory

Windows: Download the mrswin.exe file to a temporary directory


Installing on AIX

  1. Log on as the "root" user
  2. Insert the CD-ROM into your CD-ROM drive
  3. Mount the CD-ROM
    • create directory /cdrom if one does not exist
    • mount -v cdrfs -r' ' /dev/cd0 /cdrom
  4. Change to the directory where the INSTALLP file , mrsaix.lpp, is located. On the CD-ROM it will be in the /cdrom/config/aix directory. If you downloaded the mrsaix.lpp file from the Web, change to the directory where the file exists.
  5. Run SMIT and do the following:

Note: The following steps are slightly different depending on your level of AIX.

AIX 4.2 procedure

  1. Select Software Installation and Maintenance
  2. Select Install and Update Software
  3. Select Install and Update from Latest Available software
  4. Select Input device/directory for software
  5. Enter the fully qualified file name of the INSTALLP file from the CD-ROM or the Web

Note: If you are in that directory already this becomes './mrsaix.lpp'.

  1. Press PF4 to list the software and select the installation program.
  2. Select OK
  3. Select OK again
  4. Select Done
  5. Select Cancel.

AIX 4.1.5 procedure

  1. Select Software Installation and Maintenance
  2. Select Install and Update Software
  3. Select Install/Update Selectable Software (Custom Install)
  4. Select Install Software Products at Latest Level
  5. Select Install New Software Products at Latest Level
  6. Enter the fully qualified file name of the INSTALLP file from the CD-ROM or the Web

Note: If you are in that directory already this becomes './mrsaix.lpp'.

  1. Press PF4 to list the software and select the installation program
  2. Select OK
  3. Select OK again
  4. Select Done
  5. Select Cancel
  1. Unmount the CD-ROM:
    Enter unmount /cdrom
  2. Enter exit to end the root user session.

Installing on OS/2

  1. Open an OS/2 command window.
  2. Insert the CD-ROM into your CD-ROM drive.
  3. From an OS/2 command prompt, change to the /config directory on the CD-ROM.
  4. Enter os2inst.cmd and follow the prompts that appear on the panel to complete the installation.

The program creates a folder that contains the 2210 Config Program icon. There will also be an icon for the README files in the folder.


Installing on Windows

  1. Insert the CD-ROM into your CD-ROM drive.
    If you have Autorun enabled it will automatically launch a user interface.
    Select "Install Configuration Program". Otherwise, change directory to cdrom/config/win and run setup on the CD-ROM.
  2. Follow the prompts that appear on the panel to complete the installation.

— IBM Configuration Program Documentation, Sixth Edition (June 1999). Additional corrections made by ibmfiles


Multiprotocol Routing Services (MRS) Version History

MRS/MRNS Version Release Information / Code Level Date Product ID
MRS V3.4 Release Notes 10/29/99 DI2505
MRS V3.4 Installation and Usage Instructions 10/29/99 DI2504
MRS V3.4 Code Levels and Fix Summaries 04/13/2000 DI2506
MRS V3.4 PTF NP01096 04/10/2000 DL2788
MRS V3.4 PTF NP01095 02/29/2000 DL2721
MRS V3.4 PTF NP01094 11/19/99 DL2614
MRS V3.3 Release Notes 06/04/99 DI1871
MRS V3.3 Installation and Usage Instructions 06/04/99 DI1870
MRS V3.3 Code Levels and Fix Summaries 04/13/2000 DI1872
MRS V3.3 PTF NP01071 04/10/2000 DL2787
MRS V3.3 PTF NP01070 02/29/2000 DL2720
MRS V3.3 PTF NP01069 11/12/99 DL2580
MRS V3.2 Release Notes 10/28/98 DI1008
MRS V3.2 Installation and Usage Instructions 10/22/98 DI0956
MRS V3.2 Code Levels and Fix Summaries 04/13/2000 DI1009
MRS V3.2 PTF NP01068 04/10/2000 DL2786
MRS V3.2 PTF NP01067 02/11/2000 DL2719
MRS V3.2 PTF NP01066 11/12/99 DL2579
MRS V3.1 Config Program README PTF NP01028 07/20/99 DI2226
MRS V3.1 Config Program, PTF NP01028 (July 1999) 07/20/99 DL2227
MRS V3.1 Config Program README PTF NP01021 06/04/99 DI1884
MRS V3.1 Config Program, PTF NP01021 (June 1999) 06/04/99 DL1885
MRS V2.2 Config Program, PTF NP00979 (February 1999) 02/24/99 DL1502
MRS V2.2 Config README PTF NP00979 02/23/99 DI1501
MRS V2.2 Config Program, PTF NP00945 (December 1998) 12/15/98 DL1287
MRS V2.2 Config README PTF NP00945 12/15/98 DI1286
MRS V2.1 Config Program, PTF NP00919(June 1998) 06/09/98 DL0396
MRS V2.1 Config README PTF NP00919 06/09/98 DI0654
MRS V2.1 Config Program, PTF NP00864 (June 1998) 06/08/98 DL0395
MRS V2.1 Config README PTF NP00864 06/08/98 DI0397
MRS V1R1.0/V2.0 Config Program, PTF NP00901 (April 1998) Recommended Level 04/17/98 DL0240
MRS V1R1.0/V2.0 Config README PTF NP00901 04/17/98 DI0240
MRNS V1R3.2 Config Program, 1.3 Enhanced (August 1996) 08/01/96 DL0362
MRNS V1R3.1 Config Program, PTF NP00795 (January 1997) Recommended Level 01/01/97 DL0363
MRNS V1R3.1 Config README PTF NP00795 01/01/97 DI0514
MRNS V1R3.0 Config Program, GA Version (December 1995) 12/01/95 DL0366
MRNS V1R3.0 Config README GA Version 12/01/95 DI0366
MRNS V1R2.0 Config Program, PTF NP00581 (October 1995) Recommended Level 10/01/95 DL0367
MRNS V1R2.0 Config README FIRST PTF NP00581 10/01/95 DI0367
MRNS V1R2.0 Config README PTF NP00581 10/01/95 DI0484

2210 Storage Estimate Program

The Storage Estimate Program contains the algorithm to assist in determining which memory configuration is appropriate for a given customer's network.

The program considers the number of Data Link Switching sessions as well as the number of partners to be supported.

You may download 2210stor.cmd (20K), the 2210 Storage Estimator OS/2 Version.

— Product information from the deprecated IBM networking site

Note: while IBM says the .CMD is for OS/2, there were also two other unlisted files (a .REXX script and a .EXE). It's possible the .EXE is for Windows and the .REXX is for AIX, although humorously OS/2 also handles .REXX. And then technically you can run Windows programs in OS/2 with its Win16 subsystem... so maybe they can be mix and matched, I don't know.


The Legacy Multiprotocol Router Library

There used to be a legacy library from the prior documentation system in 1997. The documents would later be updated but there was no conversion process specifying which of these prior listings map to the newer documents. I've mapped the corresponding PDFs to the order numbers with the modern MRS 3.3 PDF that corresponds to the original book title to the left. These ones never made it into the list originally for whatever reason: SC30-3992-01, SG24-4956-00. Even more strange, both the CD and legacy listings omit SG24-4446-02, and I believe SG24-4446-01 was only ever a special order (but -- with so many documents, it's enough to make anyone jump out a window).

IBM 2210 NWays Multiprotocol Router Library

The IBM 2210 Library consists of several books and on-line information. The information is supplemented by a set of release notes.

Library Overview

The following list shows the books in the IBM 2210 Nways Multiprotocol Router library, arranged according to tasks.

Book Title + Info Name Date Document Order No.
book 2210 Maintenance Information: The book is shipped with the IBM 2210. It provides instructions for diagnosing problems with and repairing the IBM 2210. E2FV4003 10/04/96 13:53:55 SY27-0345-03 SY27-0345-06
book 2210 Planning and Setup Guide: This book is shipped with the IBM 2210. It explains how to prepare for installation, install the IBM 2210, perform an initial configuration, and verify that the installation is successful. This book provides translations of danger notices and other safety information. E2FD0003 10/04/96 14:51:20 GA27-4068-03 GA27-4068-05
book ELS Messages Guide: This book contains a listing of the error codes that can occur, along with descriptions and recommended actions for the errors. E2FM4005 01/22/97 07:31:58 SC30-3682-05 SC30-3992-01
book IBM 2210 Models 1Sx and 1Ux Installation Guide E2FD1000 10/24/96 13:47:57 GC30-3867-00 GC30-3867-02
book MAS/MRS V1R1 Config Pgm User's Guide E2FG4001 10/02/96 01:04:26 GC30-3830-01 GC30-3830-06
book MRS V1R1 Protocol Configuration Reference Volume 1: This book describes how to access and use the IBM Nways Multiprotocol Routing Network Services command-line router user interface to configure and monitor the protocol software shipped with the router. It includes information about each of the protocols that the IBM 2210 supports. E2FF4004 10/22/96 15:33:38 SC30-3680-04 SC30-3680-09
book MRS V1R1 Protocol Configuration Reference Volume 2 E2FD2000 10/24/96 13:38:28 SC30-3865-00 SC30-3865-05
book MRS V1R1 Software User's Guide: This book explains how to: Configure, monitor, and use the IBM Nways Multiprotocol Routing Network Services software shipped with the router. Use the IBM Nways Multiprotocol Routing Network Services command-line router user interface to configure and monitor the network interfaces and link-layer protocols shipped with the router. E2FB5004 10/23/96 15:13:44 SC30-3681-04 SC30-3681-09

— Product information from the deprecated IBM networking site


2210 Configuration Programs

This is purely historical and no longer relevant due to predating MRS 3.x ("MRNS" was the old version before MRS) and the CD IBM would later provide: I imagine back then people may not have always had an internet connection or the license info on hand, so the CD was probably ultimately created to solve those problems -- later units always shipped with the MRS 3.3 CD. For all intents and purposes you really want to install MRS 3.3 (or higher), instead.

2210 Configuration Programs

To download the desired version of the configuration program, select one of the highlighted items in the list below. There are two ways you can download the configuration program files:

  1. AIX Runtime: Files in this directory are for running on AIX hosts. Download these files on an AIX host and run the program.
  2. Diskettes: Files in this directory are the diskette images in PKZIP format. Download these files to create diskettes (PKUNZIP) to install on DOS/Windows, OS/2 or AIX hosts.

Note: Be sure to select the version of the configuration program that matches the level of router software for your router. See the 'matrix' under Other 2210 links below.

About Nways MRS and Nways MRNS.

Multiprotocol Routing Services (MRS) Configuration Programs

Release Images Info Date
2.1.0 Diskette Images, AIX Runtime GA version, Recommended level September 1997
1.1.0.0 Diskette Images, AIX Runtime NP00792, Recommended level July 1997
1.1.0.0 Diskette Images, AIX Runtime GA version January 1997

Multiprotocol Routing Network Services (MRNS) Configuration Programs

Release Images Info Date
1.3.2.0 -- This Configuration program has ISDN BRI adapter support, and PAP/CHAP. --
1.3 Diskette Images, AIX Runtime Enhanced August 1996
1.3.1.0 Diskette Images, AIX Runtime PTF NP00795, Recommended level Jan 1997
-- Diskette Images, AIX Runtime PTF NP00671 June 1996
1.3.0.0 Diskette Images, AIX Runtime GA version December 1995
1.2.0.0 Diskette Images, AIX Runtime PTF NP00581, Recommended level October 1995
-- Diskette Images, AIX Runtime GA version April 1995

Other 2210 links

  • 2210 MRS/MRNS-to-Configuration matrix. Access a cross reference between each 2210 Configuration Program release and the associated release of Nways MRS or Nways MRNS.
  • 2210 code. Download 2210 router software. Requires IBM password.
  • User notes. Get user notes to be aware of when using the configuration tools.

— Product information from the deprecated IBM networking site

Note: "https://web.archive.org/web/19971021210914/ftp://ftp:networking.ibm.com/pub/products/router_misc/2210cfg.html" for "2210 MRS/MRNS-to-Configuration matrix" was never archived by the wayback machine. And it should go without saying, but neither was the FTP on "https://web.archive.org/web/19970111044344/http://www.raleigh.ibm.com/220/220ptfs.html".


Nways MRS and Nways MRNS - Providing 2110 Software Functions

IBM Nways Multiprotocol Routing Services (Nways MRS) succeeds IBM Nways Multiprotocol Routing Network Services (Nways MRNS) and includes functions currently available in Nways MRNS Release 3 Enhanced as well as new functions not currently available.

IBM Nways MRS is a member of IBM's family of multiprotocol services products that includes Nways Multiprotocol Access Services (Nways MAS) for the IBM 2216 Nways Multiaccess Connector and Nways Multiprotocol Switched Services (Nways MSS) for the IBM 8210 Nways MSS Server and IBM 8260 Nways MSS Module. Together, IBM's three multiprotocol services products provide the benefits of switching, distributed routing, bridging and virtual LANs and enable the implementation of Switched Virtual Networking (SVN). It is IBM's comprehensive, high-performance framework to implement enterprise-wide network computing.

New functions in Nways MRS not previously available in Nways MRNS include support for:

  1. New, entry-level 2210 models
  2. New adapters for the high-end 2210 models
  3. Multiprotocol encapsulation over ATM including Classical IP and IPX as well as ATM Forum-compliant LAN Emulation client
  4. Expanded SNA capabilities including High Performance Routing (HPR), Dependent Logical Unit Requester (DLUR), Intermediate Session Routing (ISR), and APPN Version 2 Network Node (NN)

In addition, Nways MRS provides Border Gateway Protocol (BGP) Version 4 and does not support the Exterior Gateway Protocol (EGP) available in Nways MRNS.

— Product information from the deprecated IBM networking site


MRS Configuration Tool - User Notes

MRS Configuration Tool - User Notes

Last update: 06/27/97

It is important to read the README file that comes with the configuration tool.

When you report problems with the MRS configuration tool, please submit the cfg.err file along with any online information that you can obtain.

The following lists user notes to be aware of when using the MRS configuration tools.


User Notes

  1. Installation: Under Windows some users have had problems with the installation procedure erasing files in the C: directory. Please backup the C: directory to a shadow prior to installation. Please read the README file prior to installing.
  2. IP: When attempting to add a second IP Access Control entry, error message ACXE0026 is displayed (this entry is already in the list). The second entry is not accepted by the MRS V1R1 Configuration Program. These two access control entries were configured successfully with a previous MRNS configurator. They can be configured successfully using the 2210 user interface.
  3. Configuration Transfer: When transferring a configuration from the configurator to the router, the access control type (inclusive or exclusive) for IP access Control filter list entries is reversed. When viewing access control records from the 2210 user interface, entries configured by the configurator as "inclusive" show type "E" and those configured as "exclusive" show type "I".
  4. Token Ring interface speed: Previous cfg had the speed at 4MB, and when it was brought in the tool changed it to 16MB, which is the default for MRS. Appears to happen only when you do the read router or retrieve function.
  5. Display: Tool displays a translucent box that you have to click on a second time to see the data.
  6. x.25: When PVCs are previously defined and read into the tool, they disappear.
  7. Filters: Configuration Program allows user to configure IP Access Control Packet Filtering without filling in a name for the packet filter. When this configuration is loaded into the 2210, talk 6 displays the filter name as " " in some cases and "blank" in other cases. Talk 5 does not display the filter. The 2210 talk 6 configuration does not allow the user to configure a packet filter without assigning a filter name.
  8. ISDN and SAPs: When configuring ISDN dial circuits with the configurator, DLS interfaces panel does not allow selection of dial interfaces, preventing the opening of SAPs on the ISDN dial circuits.
  9. SAP F4: SAP F4 IS automatically added even when filtered.
  10. APPN: Default was enable for each interface and thus forced users to disable for each interface. (FIXED IN NP00790)
  11. RPS Problem: When using RPS for LNM, stations may be unable to insert in ring. When a station attempts to insert into a ring, it sends a Request Initialization MAC frame to the Ring Parameter Server (RPS) for that ring. If this frame is copied successfully by the RPS, then the station expects to receive an Initialize Ring Station MAC frame back from the RPS. If no such frame is received, the station will not insert into the ring. If the IBM 2210 is configured for LNM, it may become the Ring Parameter Server. A station will fail to insert into the ring if the IBM 2210 is the Ring Parameter Server and enters a congested state that prevents the sending of the Initialize Ring Station MAC frame. The solution: disable RPS on the affected port.

— Product information from the deprecated IBM networking site


2210 RLAN Clients (DIALs)

Unfortunately these were located on the now-defunct IBM networking FTP, I did not know of this page when I rescued what I could (that is, if the FTP even still had these in 2014). These (or rather newer versions most likely) should be on the 2210 CD (SK2T-0404-05).

To download the desired version of the client program, select one of the highlighted items in the list below.

Diskettes:.Diskette image files with an EXE extension are self-extracting. You can create the diskette by executing the command and referencing a blank formatted diskette in a drive such as A:, for example "FILENAME A:". If a diskette image file has a DSK extension you must use the LOADDSKF utility to expand it to a diskette. Use an archiving tool such as PKUNZIP for files with a ZIP extension.

Binary Name Info Date Size
823W95C1.EXE DIALs for Windows 95 (1 of 3) 9/24/97 1,139,333 bytes
823W95C2.EXE DIALs for Windows 95 (2 of 3) 9/24/97 1,381,367 bytes
823W95C3.EXE DIALs for Windows 95 (3 of 3) 9/24/97 1,152,299 bytes
501P1.EXE DIALs for Windows 95 Patch Version 1 (Requires installed DIALs for Windows 95 client) 5/21/98 123,075 bytes
823EDIW1.EXE DIALs for Windows (1 of 3) (Version 4.52) 3-10-97 1,188,015 bytes
823EDIW2.EXE DIALs for Windows (2 of 3) (Version 4.52) 3-10-97 1,189,497 bytes
823EDIW3.EXE DIALs for Windows (3 of 3) (Version 4.52) 3-10-97 942,578 bytes
823EDI21.EXE DIALs for OS/2 (1 of 2) (Version 4.53) 5-12-97 1,312,302 bytes
823EDI22.EXE DIALs for OS/2 (2 of 2) (Version 4.53) 5-12-97 646,227 bytes
823EDOW1.EXE DIALOUT for Windows (1 of 1) (Version 4.5) 3-10-97 739,817 bytes
823EDO21.EXE DIALOUT for OS/2 (1 of 1) (Version 4.52) 3-10-97 1,228,884 bytes
823EDO91.EXE DIALOUT for Windows 95 (1 of 1) (Version 4.5) 3-10-97 1,177,502 bytes

— Product information from the deprecated IBM networking site


News - Using Frame Relay and the IBM 2210

New Inexpensive Method for Attaching IBM 5394s to AS/400s Using Frame Relay and the IBM 2210

Are you looking for the most cost effective way to attach 5394 controllers over frame relay to your AS/400s? IBM has just made available the new 2210 custom feature RPQ 8Q1566 that allows 5394 controllers to be attached to the 2210 via SDLC and then connected over frame relay to AS/400s.

In the past, the 5394, being a PU type 1, could not be defined so as to connect to the AS/400 using frame relay UNTIL it was converted to a PU type 2.1 (full APPN network node). This PU 2.1 conversion required an expensive upgrade to the 5394 (RPQ 8Q0775, $1250 U.S.) (or even replacement with a 5494 model EXT).

Now for the GOOD NEWS !!

IBM now offers custom feature RPQ 8Q1566, the 5394 Connectivity RPQ for the 2210, for a list price of only $110 in the U.S. This 2210 RPQ is available in other parts of the world with simliar pricing.

A base token-ring 2210 model 121 with RPQ 8Q1566 (for SDLC communication with the 5394), enabled for frame relay connection to an upstream AS/400, has a list price starting at $2,605 U.S. For comparison, a competitor's solution providing SDLC connectivity and requiring the 5394 RPQ 8Q0775 starts at $5,795 U.S. list; depending on the software chosen, this price difference could be even greater.

This is a 122% list price advantage for you if you use IBM products.

RPQ 8Q1566 is available on all models of the 2210 Nways(tm) Multiprotocol Router. Purchase of a 2210 is required when ordering this RPQ. This RPQ must be ordered for each 5394 requiring attachment to the 2210. Non-switched SDLC attachment is supported at speeds up to 19.2 Kbps or 64 Kbps depending on the interface. This RPQ does not support 5294 Emulation mode, and supports attachment to an AS/400 only. (Contact your IBM representative for a detailed description of RPQ 8Q1566.)

Given the pricing of the 2210 and the difference in price between the alternatives, the IBM 2210 becomes the low-priced solution for 5394 users who want to attach to frame relay... even if there is no LAN requirement... and especially when compared with other no-LAN FRADs that use RFC 1490 protocols to communicate via frame relay to an AS/400.

— Product information from the deprecated IBM networking site


Improved Availability

IMPROVED AVAILABILITY for 2210 NWAYS MULTIPROTOCOL ROUTER and SOFTWARE

On October 8, 1996, IBM announced new 2210 Nways Multiprotocol Router models and features and a new 2210 software product - Nways Multiprotocol Routing Services (Nways MRS) as a follow-on to Nways Multiprotocol Routing Network Services (Nways MRNS).

Those products are now generally available - an earlier availability than the originally announced date of January 31, 1997. In addition, the 2210 Nways Multiprotocol Router models 1U4 and 1U8 for the United States and Canada, originally scheduled for general availability on March 28, 1997, are now generally available.

Nways MRS is available preloaded on 2210's built following this general availability, or as a no-charge upgrade for existing customers assuming no change in the software suite selected.

In addition, this 2210 release includes the following new items:

  1. 2210 Configuration Program supporting Nways MRS
  2. 32 MB DRAM feature (Feature Code 4032) for 2210 models 14T, 24T, 24E, and 24M.
  3. "Single packaging option" feature (Feature Codes 9501 - Base Suite and 9502 - Additional Routing Suite) in the United States so that the following materials are shipped with the 2210 instead of in a separate box: softcopy publications on a CD-ROM, Configuration Program diskettes, and a User Memo with information concerning how to access the IBM server that contains 2210 code.
  4. 2210 Diagnostic Program with support for the new 2210 models and features.

Additional information on 2210 hardware and software is available from a number of sources including:

  1. Other sections of this Home Page
  2. Your IBM sales representative or remarketer

In addition, IBM customers can use IBM LINK to access a variety of information.

— Product information from the deprecated IBM networking site


Performance Results: Release 3.0

IBM 2210 Nways Multiprotocol Router Performance Results: Release 3.0

Abstract:

This document presents the results of performance measurements for the IBM 2210 Nways Multiprotocol Router. The measurement results reflect the performance of the IBM Nways Multiprotocol Routing Services (MRNS) Version 1 Release 3.0 unless indicated as results from an earlier release.

Release 3.0 includes both new harware (14T, 24T, 24E, 24M) and software functional enhancements.

These performance results provide information on throughput, latency and other performance related issues for the LAN and WAN media and communication protocols supported by the 2210 including Data Link Switching (DLSw) and bridging.

Download a 2.2 Meg Postscript PDF copy of the report.

— Product information from the deprecated IBM networking site


IBM Nways Multiprotocol Routing/Access Services Version 1 Release 1

The MRS software is based on a large set of standards. These standards, draft standards, and proposed standards are issued by the Internet Activities Board and distributed by the Network Information Center. They are referred to by RFC (Request for Comments) numbers:

The following list represents the RFCs supported by the MRNS. This list is subject to future update/correction as additional information is available.

  • RFC 768 User Datagram Protocol (UDP)
  • RFC 783 Trivial File Transfer Protocol
  • RFC 791 Internet Protocol (IP)
  • RFC 792 Internet Control Message Protocol (ICMP)
  • RFC 793 Transmission Control Protocol (TCP)
  • RFC 826 Ethernet Address Resolution Protocol (ARP)
  • RFC 854 TELNET Protocol
  • RFC 877 IP over DDN X.25 (obsoleted by RFC 1356)
  • RFC 888 "STUB" Exterior Gateway Protocol
  • RFC 894 Transmission of IP Datagrams over Ethernet
  • RFC 919 Broadcasting Internet Datagrams
  • RFC 922 Broadcasting Internet Datagrams in the Presence of Subnets
  • RFC 925 Multi-LAN Address Resolution
  • RFC 950 Internet Standard Subnetting Procedure
  • RFC 951 Bootstrap Protocol (BOOTP)
  • RFC 1009 Requirements for Internet Gateways
  • RFC 1027 Using ARP to Implement Transparent Subnet Gateways (Proxy-ARP)
  • RFC 1042 Transmission of IP Datagrams over IEEE 802 Networks
  • RFC 1058 Routing Information Protocol (RIP)
  • RFC 1075 Distance Vector Multicast Routing Protocol (DVMRP)
  • RFC 1112 Host Extensions for IP Multicasting
  • RFC 1122 Requirements for Internet Hosts - Communications Layers (missing some support but being addressed)
  • RFC 1123 Requirements for Internet Hosts
  • RFC 1139 OSI Echo
  • RFC 1144 Compressing TCP/IP headers for Low-Speed Serial Links
  • RFC 1155 Structure and Identification of MIBs
  • RFC 1156 MIB-I (obsoleted by RFC 1213)
  • RFC 1157 SNMP
  • RFC 1171 The Point-to-Point Protocol (PPP) (obsoleted by RFC 1331 and 1548)
  • RFC 1172 PPP Initial Configuration Options (obsoleted by RFC 1332 and 1549)
  • RFC 1191 Path MTU Discovery
  • RFC 1212 Concise MIB Definitions
  • RFC 1213 MIB-II
  • RFC 1220 PPP Extensions for Bridging
  • RFC 1231 Token Ring MIB (obsoleted by RFC 1748)
  • RFC 1236 IP to X.121 Address Mapping for DDN
  • RFC 1243 AppleTalk MIB
  • RFC 1247 OSPF Version 2 -- TOS not supported (obsoleted by RFC 1583)
  • RFC 1253 OSPF Version 2 MIB
  • RFC 1256 ICMP Router Discovery Messages
  • RFC 1284 Ethernet MIB (obsoleted by RFC 1398)
  • RFC 1286 Bridge MIB (obsoleted by RFC 1493, 1525)
  • RFC 1293 Inverse Address Resolution Protocol (InARP)
  • RFC 1294 Multiprotocol Interconnect over Frame Relay (obsoleted by RFC 1490)
  • RFC 1315 Frame Relay MIB
  • RFC 1317 RS-232 MIB
  • RFC 1331 Point-to-Point Protocol (PPP) (obsoleted by RFC 1548)
  • RFC 1332 PPP Internet Protocol Control Protocol (IPCP) (obsoleted by RFC 1549)
  • RFC 1334 PPP Authentication Protocols
  • RFC 1338 Supernetting (CIDR) (obsoleted by RFC 1519)
  • RFC 1350 TFTP Version 2
  • RFC 1356 Multiprotocol Interconnect over X.25 and ISDN
  • RFC 1362 IPXWAN -- PPP only (obsoleted by RFC 1551)
  • RFC 1378 PPP AppleTalk Control Protocol (ATCP)
  • RFC 1398 Ethernet MIB (obsoleted by RFC 1623)
  • RFC 1434 DLSw
  • RFC 1471 PPP MIB
  • RFC 1483 Multiprotocol Encapsulation over ATM Adaptation Layer 5
  • RFC 1490 Multiprotocol Interconnect over Frame Relay (obsoletes RFC 1294)
  • RFC 1493 Definitions of Managed Objects for Bridges (obsoletes RFC 1286)
  • RFC 1519 Classless Inter-Domain Routing (CIDR)
  • RFC 1525 Definitions of Managed Objects for Source Routing Bridges (obsoletes RFC 1286)
  • RFC 1541 Dynamic Host Configuration Protocol (DHCP) (same relay-agent support as for BootP)
  • RFC 1542 Clarifications and Extensions for the Bootstrap Protocol (obsoletes RFC 1532)
  • RFC 1548 The Point-to-Pont Protocol
  • RFC 1549 PPP in HDLC Framing
  • RFC 1552 The PPP Internetwork Packet Exchange Control Protocol (IPXCP)
  • RFC 1573 Evolution of Interfaces Group of MIB-II
  • RFC 1577 Classical IP and ARP over ATM
  • RFC 1583 OSPF Version 2 -- TOS not supported (obsoletes RFC 1247)
  • RFC 1584 Multicast Extensions to OSPF (MOSPF)
  • RFC 1593 SNA APPN Node MIB
  • RFC 1618 PPP over ISDN
  • RFC 1623 Ethernet MIB (obsoleted by RFC 1650)
  • RFC 1626 - Default IP MTU for use over ATM AAL5
  • RFC 1650 Definitions of Managed Objects for the Ethernet-like Interface Types
  • RFC 1654 Border Gateway Protocol (BGP) 4
  • RFC 1657 Definitions of Managed Objects for BGP-4
  • RFC 1666 Definitions of Managed Objects for SNA NAUs
  • RFC 1695 Definitions of Managed Objects for ATM Management Version 8.0
  • RFC 1747 Definitions of Managed Objects for SNA Data Link Control: SDLC
  • RFC 1748 IEEE 802.5 MIB
  • RFC 1755 ATM Signalling Support for IP over ATM
  • RFC 1763 Banyan VINES Control Protocol over PPP
  • RFC 1795 AIW Version 1 Data Link Switching (DLSw)
  • RFC 1812 Requirements for IP Version 4 Routers (obsoletes RFC 1716)

— Product information from the deprecated IBM networking site


IBM 2210 Wins Data Communications Tester's Choice

Winner of DataComm magazine's Tester's Choice award

"This is the most prestigious award that we give... and it's earned only after we've tested a product -- head -to-head and in our own laboratories -- with the best the rest of the industry has to offer. You should be proud, the IBM 2210 router clearly is the price/performance leader in the industry."

— Joe Braue, Publisher of Data communications Magazine

With those words, Braue officially presented Networking Hardware employees with his publications "Tester's Choice" award. Data Communications originally announced the honor in the July, 1996 issue, due to scheduling conflicts, the award was presented in February of 1997.

"No question about it, the 2210 is an integral part of our growing presence in the merging of traditional SNA and network computing environments," sad Jose Garcia, General Manager of the Access Business Segment. "This product is generally considered to be the fastest growing product in its segment of the router market...it's a great place to build from for IBM."

Data Communications praised the 2210 for its ability to direct up to 3,000 simultaneous SNA sessions in a shared SNA - TCP/IP environment. In addition, it proved to be best at allowing customers to customize their networking environments for a combination of SNA and TCP/IP traffic through prioritization features.

"The development and testing of this product was a groundbreaking experience," said Peter Gayek 2210 D1Sw development team. "This team has come up with a router that is best of breed and really shows IBM is serious about competing in both the router and switching markets for networking products."

Products such as the 2210, which enable a seamless shared environment are in strong demand.

IBM estimates there are more than 50,000 mainframe based corporate networks and more than 400,000 networks with AS/400's, all running on the most prevalent corporate protocol, SNA. Without products such as the 2210, corporate net managers often have to maintain separate infrastructures for SNA and TCP/IP.

For the team that developed the 2210 router, the Data Communication award points the way to future success for the Networking Hardware Division in an important market for IBM.

The newest version of the 2210 was just released in January 1997, and we did all the development within IBM. It's a good measure of how we're gathering momentum in the router market," Gayek said.

2210 team

The 2210 Team

— Product information from the deprecated IBM networking site


AS/400 Promotional Offer

This was a special questionnaire that could be submitted to see how the 2210 could be configured in your environment.

A special offer for AS/400 users who need a multi-protocol, multi-site network. Just request our free guide and you'll find out all you need to know. (And you won't have to wait until the clocks go back to fit it in.)

open 25 hours

OK. We know you're busy, so we'll keep this short. Right now, you probably have a list of a thousand things your organization wants you to do. And we know that creating a multi-site, multi-protocol network always seems to take second place. And who's to blame you? Yes, it's an important strategic issue for your business, but won't it require a complete overhaul of your burgeoning systems and LANs? And won't that take months? Not to mention the kind of budgets that contain a single figure followed by a lot of zeros? Well, actually, it doesn't have to. You see, there is a way to build the kind of network that hooks all your people (and all your suppliers and clients) together using the AS/400¨ network you already have. By using solutions like the IBM 2210 NwaysTM Multi-protocol Router you can connect all kinds of networks to each other - from Token-Ring to Ethernet and SNA to IP - and you can protect your investment in the IBM 5394 and 5494 Remote Controllers that form the backbone of your network today. Of course, learning how to do all this will take some time, won't it? Again, it doesn't have to. Most of what you'll need to do is clearly laid out in a guide we've put together just for AS/400 users like you. And once you've had the chance to read through it, we'll put you in touch with the people who can help you implement your multi-protocol, multi-site network swiftly, painlessly and cost-effectively - our network of IBM Business Partners.

Take two minutes right now to request your free guide. Just complete and submit this Questionnaire. This offer is good in the US and Canada only. Please take a little time to answer a few questions. To reset/clear all entries and start over, click "Reset" at the bottom of the form. Optional fields/questions are marked with an (*).

  1. What is the number of LANs in your area of influence?
  2. How many endpoints (PCs and/or Workstations) do you have in your network?
  3. Are you: an End User/IT Professional? a Reseller? a Consultant?
  4. What is your role in the purchasing process? Decision Maker. Researcher/Recommender. Other, please specify
  5. Are you planning to connect your remote and/or branch office LAN?
  6. If Yes, how soon will you be evaluating networking solutions?
  7. If Yes, has this project been budgeted for 1997?
  8. Are you currently working with an IBM Business Partner?
  9. I have a responsibility for or interest in (select all that apply): Token-Ring LANs. Ethernet LANs. Remote LAN Access (Mobile computing)

— Product information from the deprecated IBM networking site


Price Chart (Historical)

The original price chart from 1996.

Item Part Number Feature/Model Price (USD) Availability
Router 2210 1S4 $1150 1/97
Router 2210 1S8 $1550 1/97
Router 2210 1U4 $1150 3/97
Router 2210 1U8 $1550 3/97
25M ATM Adapter 2210 14T/3901 $2195 1/97
T1/J1 ISDN Primary 2210 24T/3107 $2695 1/97
4-Port WAN Concentrator 2210 24E/3120 $1295 1/97
8-Port WAN Concentrator 2210 24M/3121 $2195 1/97
32-MB DRAM Expansion (Models 14T, 24T, 24E, 24M) 2210 4032 $1995 1/97
Single Package 2210 Base Suite Customers 1S4, 1S8, 12T, 12E, 127, 128, 14T, 24T, 24E, 24M/ 9501 -- 1/97
Single Package 2210 Base Suite Customers 1U4,1U8/ 9501 -- 3/97
Single Package 2210 Additional Routing Suite Customers 1S4, 1S8, 12T, 12E, 127, 128, 14T, 24T, 24E, 24M/ 9502 -- 1/97
Single Package 2210 Additional Routing Suite Customers 1U4, 1U8/ 9502 -- 3/97
Language Group Features 2210 US English 1S4, 1S8/ 9400 -- 1/97

Table 1. Part Numbers, Prices, Availability


Connecting via Console

It appears the standard baud rate is very finnicky with these (or maybe it was just my cable/setup at the time). I had to set it lower when connecting. Another issue is that their firmware appears to get corrupted easily over time and needs to be reflashed (via the PROM above???). I still need to reflash mine. A small 2026 update: as I am refreshing my networking closet I am getting interested in this again (and also updated this page with dramatically more information). I would like to add that you DO NOT need to use an IBM 2210-24M for bridging Ethernet and Token Ring, this can just be done with a PC running Linux or virtually anything else that has both an Ethernet and Token Ring NIC. However, as I find this router particularly interesting for all of the wrong reasons, I would like to get it fully functional with MRS in OS/2.

🏠 Home | ⬅ Back | ⬆ Top